Community - AOU MOD Public Beta!

Newsentries to be discussed

Moderators: AOU Team, Forum Moderators, Site Managers

Community - AOU MOD Public Beta!

Postby Windguaerd » Sat Apr 04, 2009 1:39 pm

Yes, we're making the AOU MOD a public BETA (currently version 0.9.2.9). The awesomeness of this Mod (the first of it's kind, no longer just an AOU GUI Skin) is that we have managed to push skinning to a new level (we hope) bringing you a very flexible GUI, new tools and fun voicepacks. Lots of blood, sweat, tears and leet pie went into the making of this Mod. Unfortunately no Cyborgs, Hecks or Cred Spammers were harmed though.

This version is fully compatible with 18.0.2 (if you were wondering).

I will try to list everything that comes with it, including extra GUI features that you won't find in the original AO GUI.

* New AO Launcher Skin.
* New AO Login Load Screen, featuring the classic AO logo, revamped!
* AriensGUI Panel
* AriensGUI VoicePack
* Windguaerd's Line of Fire VoicePack v4.0
* Windguaerd's Alien Database v3.0
* New AO GUI Skin with the following modified/added Features:

- Thin curved HP/XP/AXP/NANO bars which can either be placed in the left wing dock or around your character which allows you to keep track of your health and nano better during combat.
- Enhanced Control Center allowing every bar, menu, button to be visually removed from view including the NCU/Credits Bar and the Agg/Def Bar.
- New AOU Menu, allowing in-game access to AriensGUI, Ariens Voicepack, Windguaerd's Line of Fire Voicepack v4.0, Windguaerd's Alien Database v3.0 which can be toggled on and off in the Control Center.
- Added "Leet Pets" in the "Options" menu so you can request/accept/decline/stop a leet duel.
- Added "Lag Config" in the "Options" menu with 9 different settings which are: DeLag PvP, DeLag Raid, DeLag Alien Raid, Default View, Full View, Reduce View Distance, Max View Distance, Reduce Char Distance, Max Char Distance.
- Added /hug to the list of emotes.
- Added Raid Button to Team Menu.
- Revamped "Ding" Icons that pop when you have completed a Research Line, reached a new level, reached a new ai level, gained a new perk point.
- Changed the Raid Interface Profession Icons, so that players can actually work out who they are teamed with.
- Funky Yalm cursor!
- Wider Compass.

*A couple of easter eggs hidden within the Mod.... good luck finding those!

*Instructions,txt file included, with specific details on how to install this Mod. Please ignore the line that starts with "Verbal abuse by" otherwise a cute cat will die for every letter you read after that.

The AOU Mod is 18.7MB in a zip file, you can get it from our downloads section here.

We have been getting a lot of feedback from the sneak peeks and now it's time for the community to test this baby and give us as much feedback as possible so we can make this the first and most awesome AO Mod in the universe!

What are you waiting for? download it NOW!
Twitch Channel - Youtube Channel - Twitter - Facebook - Pinterest
AO Universe - Site Founder (Retired) | AOSpeak - Founder (Retired) | AO RecipeBook - Founder (Retired)

Keep in mind: My posts/views are not representative of AO-Universe in any way, shape or form. They are my own personal views and thoughts.
User avatar
Windguaerd
AOU Community Legend
 
Posts: 2731
Location: Florida

Postby Scene » Sat Apr 04, 2009 4:41 pm

version 0.9.2.9.1

- fixed a serious issue with the AOU menu that seemed to have got broken on upload, and also seemd to prevent writing back preferences
Last edited by Scene on Sat Apr 04, 2009 7:26 pm, edited 1 time in total.
User avatar
Scene
AOU Community Legend
 
Posts: 1334
Location: Devon, UK

Postby TheSeraph » Sat Apr 04, 2009 5:22 pm

hmm downloaded, installed, but noticed serious issue - when i went into character creation, etc, upon creating a toon i couldn't see any of the menus, bars, etc except inventory and hotbars...all else was invisible. I went into the settings menu via f10, it said all the bars were enabled and transparency was at 0; i tried to adjust transparency to see what it would do, and my client crashes :P

i don't know, mebbe its just me, but havent had this problem with any GUI before :P Also, another possible problem i noticed: Upon installing all necessary files and booting AO, it terminated itself saying it couldn't find 'mainprefs.xml' in the GUI folder - i copied the one from my backup and AO started fine, but is that what caused the first issue i mentioned? I haven't looked at the mainprefs.xml file to see what it affects, but i wouldn't think it should cause the GUI to be completely invisible and crash my client when i try to adjust it :P

anyways, noticed those, im about to try again to see if it was just a bad stroke of luck, or error on my part, but thought i'd go ahead and point those out to you so you atleast know ;)

like the effects that i've seen so far :P altho i kind of feel perhaps the cursor is just a tad too big? everything else pretty nice so far as I've seen ;)
<img>http://miniprofile.xfire.com/bg/wow/type/2/wolfetplayer.png</img>
<url=http://seraphhaven.110mb.com><img>http://img231.imageshack.us/img231/7752/logotx2.png</img></url>
TheSeraph
 
Posts: 3
Location: USA

Postby Scene » Sat Apr 04, 2009 5:31 pm

Make sure you change the location of the GUI to the AOU one (its in the instructions.txt)
User avatar
Scene
AOU Community Legend
 
Posts: 1334
Location: Devon, UK

Postby AlexanderW » Sat Apr 04, 2009 7:56 pm

hum ok i'm having the same issues as two posts above me and yes I switched to the GUI in the AOU folder

I can't see any menus except for the control centre (ctl-2) can not bring up my planet map, PF map compus, etc and cant chage the number of hot bars I have up


really not sure where to go from there cause if I use f10 to try and change anything the cliet crashes
AlexanderW
 
Posts: 3

Postby Scene » Sat Apr 04, 2009 8:06 pm

what skin were you using before, just out of interest, AO Default or a custom skin?

and what platform are you running on, XP or Vista?

oh and one more question...
are you making a backup of the Default folder or just renaming it?
User avatar
Scene
AOU Community Legend
 
Posts: 1334
Location: Devon, UK

Postby AlexanderW » Sat Apr 04, 2009 8:17 pm

i'm renaming the default folder

I'm on unbuntu running under wine so I'd say it'd be closer to XP than vista

I'm using a personal mod of the default gui but I do have the defaut gui backed up.

I have switched to my modded gui and it alows me to play the game with out crashing I also switched back to the default gui (I do this but removing renaming the other 2 default folders and setting the orginal folder back to default then switching back to the propper gui file)

I've found that other custom GUIs will crash my client and this is the first one thats actually allowed me to get into the game seeing as the others have crashed before I even get a loading screen
AlexanderW
 
Posts: 3

Postby Scene » Sat Apr 04, 2009 8:22 pm

ah there in lies the problem with just renaming it... if you do a copy of it then overwrite the original with the zip contents it should work.

There are a few files I didn't bother putting into the zip because they weren't modified at all, and had no direct influence on the GUI itself.

Instead of going through the whole process again, just copy the CharPrefs.xml, MainPrefs.xml (if it isn't already in there), Variables.xml and MapCoords.xml (if you have that one) from your renamed folder into the new Default folder and it should work
Last edited by Scene on Sat Apr 04, 2009 8:44 pm, edited 2 times in total.
User avatar
Scene
AOU Community Legend
 
Posts: 1334
Location: Devon, UK

Postby TheSeraph » Sat Apr 04, 2009 8:23 pm

yes, i was using the AOU gui files ;)

before AOU mod i was running AO with the Uncluttered GUI, but all files were backed up and i reinstalled original AO gui before installing AOU..

I'm running XP, never had any probs with any other GUI's before AOU...

Switched back a minute ago to original GUI again, played fine, then reinstalled AOU, etc, still had same probs...

I was making a backup of the Default folder (renamed it DEFAULTbackup, then moved it to desktop)...

still having same prob tho :P continuing to work on it and troubleshoot, if i find a solution i'll post with it ;)
<img>http://miniprofile.xfire.com/bg/wow/type/2/wolfetplayer.png</img>
<url=http://seraphhaven.110mb.com><img>http://img231.imageshack.us/img231/7752/logotx2.png</img></url>
TheSeraph
 
Posts: 3
Location: USA

Postby Scene » Sat Apr 04, 2009 8:25 pm

looks like this could be a common issue if people just rename, I'll add those files into the next zip, if it becomes all too common.
User avatar
Scene
AOU Community Legend
 
Posts: 1334
Location: Devon, UK

Postby AlexanderW » Sat Apr 04, 2009 8:48 pm

yup you advice fixed it

GUI looks great

EDIT

I think it ever redused some lag issues I've been having
AlexanderW
 
Posts: 3

Postby TheSeraph » Sat Apr 04, 2009 8:54 pm

k i fixed it :P

works fine now, really very nice job AOU, love it :P

anyways, to fix the prob, i manually went into all subfolders of the old Default folder (like OptionPanel, ActionViews, Views, etc) and copied all the xml's...then i pasted the xml's into their corresponding NEW Default folder. If a choice came to overwrite a file, I clicked NO (was alot of that). I did this with all xml's inside the Default folder (For example, I copied Raid.xml from the folder "Views" in the backed-up Default folder. I then pasted it into the "Views" folder in the new Default folder for AOU, and if it asked if I wanted to overwrite, I said no). I then made double sure there was no trace of the old Default folder nearby the AO installation, started AO and it worked...

that being said, you were talking about adding things to the next Zip for the GUI, personally i would suggest taking a look at the original GUI folders and checking out what files exist in the old that you don't include in your new Default folder, and just paste those into it like i did...that would save others the trouble of having to do it themselves.

Thanks again for the GUI, its quite nice once it gets to working lol :P
<img>http://miniprofile.xfire.com/bg/wow/type/2/wolfetplayer.png</img>
<url=http://seraphhaven.110mb.com><img>http://img231.imageshack.us/img231/7752/logotx2.png</img></url>
TheSeraph
 
Posts: 3
Location: USA

Postby Emergency56 » Sun Apr 05, 2009 10:17 am

Is there any pics of it in action?

would like to see before i install ;)
Emergency56
 
Posts: 1

Postby Ukblizzard » Sun Apr 05, 2009 10:33 am

Ukblizzard
AOU Community Legend
 
Posts: 3223
Location: Germany

Postby Scene » Sun Apr 05, 2009 11:16 am

they're slightly older pics, and some things have changed since then, like the stat bars and the left + right wing docks, but they should give a decent enough idea
User avatar
Scene
AOU Community Legend
 
Posts: 1334
Location: Devon, UK

Next

Return to News-Corner

Who is online

Users browsing this forum: No registered users and 1 guest